Geeklets In OS X Yosemite's Notification Center (Using Today Scripts)

I have been a long time fan of GeekTool, and more recently Übersicht.  Now there is something I think is even better: Today Scripts, which puts your shell commands into Notification Center in Yosemite!

Today Scripts lets you run your Terminal commands and print the output in Notification Center for a more “native” look then you would get with GeekTool or Übersicht.

today-scripts

Here are some of the scripts I used in the screenshot.  More to come as I convert some of the GeekTool scripts.

Network

echo -e "IP address:\t$(ipconfig getifaddr en0)"
echo -e "Default Gateway:\t$(netstat -rn | grep default | grep en0 | awk '{print $2}')"

System

lastCharsInSerialNum=$(system_profiler SPHardwareDataType | awk '/Serial/ {print $4}' | cut -c 9-)
friendlyName=$(curl -s http://support-sp.apple.com/sp/product?cc="$lastCharsInSerialNum" | awk -F'<configCode>' '{print $2}' | awk -F'</configCode>' '{print $1}')
echo -e "OS X: $(sw_vers | grep ProductVersion | awk '{print $2}')"
ioreg -l | grep IOPlatformSerialNumber | cut -d'"' -f4
sysctl -n hw.memsize | awk '{print $0/1073741824" GB RAM"}';
echo -e "$friendlyName"
echo -e "$(sysctl -n hw.model)"
echo -e "$(scutil --get ComputerName)"
echo -e "SMC: $(ioreg -c AppleSMC | grep smc-version | cut -d'"' -f4)"

JSS

jssConnection=$(jamf checkJSSConnection -retry 0 | grep "available")
jamfVersion=$(jamf -version | cut -d'=' -f2)
echo -e "$jssConnection\t$jamfVersion"